Shore Power not working

JstewJstew Posts: 51Member ✭✭
2000 310 Fiesta Vee.  Shore power is plugged in and switch on the main panel is switched to shore power.  No lights coming on on the panel.  Is there some other switch somewhere else on the boat that also needs to be turned on?

Everything (including AC) works fine when the generator is on. 

Comments

  • AlswaggAlswagg Posts: 1,787Member ✭✭✭✭✭
    Are your breakers at the dock on?
  • JstewJstew Posts: 51Member ✭✭
    Yes.  The cord is charged. 
  • JstewJstew Posts: 51Member ✭✭
    Is there an isolation switch somewhere besides the panel in the cabin?
  • NavyCTRCNavyCTRC Pensacola, FLPosts: 303Member ✭✭✭
    Check on the side of the wet bar behind the drivers seat.  I have a redundant breaker next to the AC plug there.
  • MarkBMarkB OntarioPosts: 2,960Member ✭✭✭✭✭
    edited June 2016
    Do you have shore choice. If so there's ano isolation on the switch board for the port inlet and another between the aft benches for the starboard side on my 260 EC. Check those out.
    Post edited by MarkB on

    Boat Name: King Kong

    "Boat + Water = Fun"

  • aero3113aero3113 Long Island, NYPosts: 1,405Member ✭✭✭✭
    Got back to the dock tonight and I'm having the same issue on my 242. Shore power is on but no light on the panel. I didn't have time to play with it tonight but thinking either my cable went bad or the bulb on the panel blew out. Will test with my multimeter this week.
  • aero3113aero3113 Long Island, NYPosts: 1,405Member ✭✭✭✭
    Found my issue! I tested power at the cord and all was good. I looked at the plug on the boat and noticed that the bottom pin was recessed and didn't look normal to me. I took a pair of pliers to the pin and saw that it wasn't secure and was moving around. I unscrewed the plug and found that the plastic housing on the inside was broken. I was able to make it work for now till I get a new receptacle. Maybe you have the same issue @Jstew ?




  • Dream_InnDream_Inn Annapolis, MDPosts: 3,845Member, Moderator mod

    Great find aero and thanks for posting pictures!  I'm sure they will help people out.

    Dream 'Inn III -- 2008 400 Express

  • raybo3raybo3 Revere MAPosts: 3,332Moderator mod
    aero I would be very careful using that plug. Loose connections cause fires. IMO I would not use it.........
    2002 342 Fiesta Vee PC Point Of Pines YC Revere MA. popyc.org
  • aero3113aero3113 Long Island, NYPosts: 1,405Member ✭✭✭✭
    What I ended up doing was hook up the power cord with it disconnected and the plug unscrewed then I slid the black wire in for a snug fit (I made sure it's safe).I already bought the back half of the plug from West Marine so it's going to be replaced asap. Below is the link to the power inlet replacement.

    http://www.westmarine.com/buy/marinco--interior-replacement-for-power-inlet--264606?green=4A734478-FF75-531C-BAB4-BDD32289B7EA&cm_sp=Onsite-Recs-_-MB-_-PDP

Sign In or Register to comment.