Generator starts, runs and stops fine but won't accept any loading

olemiss89olemiss89 Posts: 6Member ✭✭
i have an 06 360EC with a Kohler 5kw gen. I can start and stop it locally and remotely from the interior panel. However, when I switch off all systems running, switch off shore power and switch on the generator switches I get no green light or when I try to start systems (A/C, microwave, etc.) I have no power. 
Any suggestions?

Thanks!

Comments

  • AlswaggAlswagg Posts: 2,052Member ✭✭✭✭✭
    What do you mean " switch off all systems running?     You can start the gen even when the shore power is plugged in.  Once up and running simply switch from shore to gen.   Are your batteries totally charged?
  • raybo3raybo3 Revere MAPosts: 3,582Moderator mod
    M y genny starts fine and after start up (with no load) starts "surging" when I put a heavy load on it runs fine. Shut down the load and starts surging again. Strange problem but runs every time and runs great with a load..........
    2002 342 Fiesta Vee PC Point Of Pines YC Revere MA. popyc.org
  • AlswaggAlswagg Posts: 2,052Member ✭✭✭✭✭
    Ray that is the choke.  I also suggest to replace the spark plugs every season.  These small displacement engines are running extremely lean to pass immisions.  Lean conditions wear out the tips 
  • Black_DiamondBlack_Diamond Holland, MichiganPosts: 4,139Member ✭✭✭✭✭
    ++ to Al. These eat spark plugs. Note there are (2). NGK BP4ES if I remember correct. 

    2003 342FV "Black Diamond", 350 MAG MPI, 20P 4x4 Props, PC BYC, Holland, MI
  • raybo3raybo3 Revere MAPosts: 3,582Moderator mod
    Thanks Al I do have the plugs changed every season. I will look at the choke. Again thanks
    2002 342 Fiesta Vee PC Point Of Pines YC Revere MA. popyc.org
  • explore7425explore7425 Newark, DEPosts: 150Member ✭✭✭
    edited June 2015
    Check the white switch on the generator at the top right hand corner. This needs to be on in order for power to leave the genset. Also get a multimeter and check all the fuses in the genset. I have seen a lot of blown fuses in the gensets lately. Two this weekend on our raft up believe it or not. 
    Bella Sabrina II  370EC
  • craigswardmtbcraigswardmtb Mystic, CTPosts: 969Member ✭✭✭
    That choke is a joke.  Clean the carb and choke area and see if the dieseling goes away.  Mine hassles me every season so far but comes back to life after a good cleaning.  I may replace the choke soon and hopefully it goes away for good.
  • craigswardmtbcraigswardmtb Mystic, CTPosts: 969Member ✭✭✭
    This reminds me, I need to replace the white plug that goes into the inverter on my 5e.  Where would i purchase one of these?  Or better yet, does anyone know how to get a wire back into one of the receptacles in the plug?  My red wire pulled and now the genny won't start from inside the cabin.  Opening the engine hatch everytime I want power is becoming a pain.
  • Black_DiamondBlack_Diamond Holland, MichiganPosts: 4,139Member ✭✭✭✭✭

    2003 342FV "Black Diamond", 350 MAG MPI, 20P 4x4 Props, PC BYC, Holland, MI
  • olemiss89olemiss89 Posts: 6Member ✭✭
    Great suggestions, much appreciated. I'm headed out Thursday night to do some more testing.

  • HamdogHamdog Lee's Ford Marina, Lake Cumberland in KYPosts: 247Member ✭✭
    I'm with explore on this one. Sounds like the switch on top of the generator is turned off. Same symptoms on a buddies boat this past weekend.
    "Wetted" Bliss 2005 Rinker 342 - Black Hull - Twin Mercruiser 350 Mags - BIII's
  • olemiss89olemiss89 Posts: 6Member ✭✭
    Sometimes it's easy, in this case the white switch solved it. Felt dumb not remebering that but appreciate the reminder!! Next up, windlass 90 amp fuse...
Sign In or Register to comment.